post-from-site v2.0.1

I’ve just released post-from-site v2.0.1, which fixes the unintentional bit of code left from development (that I left a path absolute from my dev environment). It should be working for everyone now, but let me know if something else is broken.

Download!

Any support questions should be asked here for v2.0.0+. I can only help if you give me information about your error: what error message you get, where in the process it’s failing, etc. I can’t do anything if you just tell me “it’s not working”.

And now I’m going to ask you all for help: I have this plugin installed here, but for some reason, the stylesheet is 404ing. It exists, and I’ve looked in firebug and the response text is the correct CSS, so I don’t understand why the browser is telling me the file doesn’t exist. Any ideas? I also had a similar problem with a JS file for a work project, and I never really solved it, just worked around it. They’re on different servers, so that’s not it. Any ideas?

EDIT 8/11/10 First thing: A co-worker figured out the 404 problem, which might be affecting others. The stylesheet calls a require_once on wp-blog-header.php which apparently does something to mess with the headers of the stylesheet (and the other files I had trouble with), so changing that to wp-load.php seems to include all the necessary functions. I’ll upload a fixed version tonight, also changing the div back to an a tag, since I got a few comments questioning that move (there honestly wasn’t much thought behind it, other than I usually ended up putting the link in a div so it would theoretically save code? Well, it’ll be an a again).
Second thing: Custom fields seem to be a much-requested item, so I’ll see what I can do. Widgetizing it also seems popular, but I’m not sure how that works so I’ll look into it before promising anything.

EDIT 12/07/10 Apparently I forgot to edit this post to say so, but I now have a forum for questions – one section is free community help, and the other is paid support where I promise to answer your questions. For that, however, you need to subscribe.

1 Comment

  1. Your post from site is only for admin and editor ? or anybody(logged in user) can access it? i am facing a problem related to this sructure. my user is logged in but its telling that you have to logged in first…plese confirm

Leave a Reply

© 2014 Kelly Dwan

Theme by Anders NorenUp ↑

%d bloggers like this: